DEMON INTERNET - CISCO IOS SURFTIME ISP CONFIGURATION EXAMPLE


Configurations below should work with all 800series, 1000series, 1600series, 2500series, 2600series, 3600series, 4x00series, 7x00series running IOS version 12.0(5)T > with IP+.

ISDN (1603)

Current configuration:

!
! Last configuration change at 02:45:07 GMT Sun Feb 11 2001 by noc
! NVRAM config last updated at 02:45:08 GMT Sun Feb 11 2001 by noc
!
version 12.0
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname c1603
!
logging buffered 16384 debugging
no logging console
enable secret EnablePassword
!
username noc privilege 1 password NocPassword
username admin privilege 15 password AdminPassword
ip subnet-zero
no ip source-route
no ip ftp passive
ip domain-list netcomuk.co.uk
ip domain-list netcom.net.uk
ip domain-list demon.net
ip domain-list demon.co.uk
ip domain-list freeserve.co.uk
ip domain-name bdsltd.co.uk
ip name-server 194.42.224.130
ip name-server 194.42.224.131
ip name-server 194.42.224.132
ip name-server 172.16.0.10
isdn switch-type basic-net3
isdn tei-negotiation first-call
clock timezone GMT 0
clock summer-time BST recurring
!
!
!
process-max-time 200
!
interface Ethernet0
 description ****   Building LAN   **** 
 ip address 172.16.0.254 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 ip nat inside
!
interface BRI0
 description **** ISDN Physical Int ****
 bandwidth 64
 no ip address
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface Dialer1
 description ***** Dialer Interface to Demon Internet Surftime  (08440416672) ****
 bandwidth 64
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer remote-name Dialer1
 dialer string 08440416672
 dialer hold-queue 100
 dialer pool 1
 dialer-group 1
 compress stac
 ppp authentication pap callin
 ppp pap sent-username DemonAccount password DemonPassword
!
interface Dialer2
 description ***** Dialer Interface to Demon Internet Surftime  (08440416672) ****
 bandwidth 64
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer remote-name DEMON
 dialer string 08440416672
 dialer hold-queue 100
 dialer pool 1
 dialer-group 1
 compress stac
 ppp authentication pap callin
 ppp pap sent-username DemonAccount password DemonPassword
!
interface Dialer3
 description ***** Dialer Interface to GTS Netcom Internet SMTP (08450798554) ****
 bandwidth 64
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer remote-name NETCOM
 dialer string 08450798554
 dialer hold-queue 100
 dialer load-threshold 240 either
 dialer pool 1
 dialer-group 1
 compress stac
 ppp authentication pap callin
 ppp pap sent-username NetcomAccount password NetcomPassword
 ppp multilink
!
interface Dialer4
 description ***** Dialer Interface to Freeserve Anytime        (08452402602) ****
 bandwidth 64
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer remote-name FREESERVE
 dialer string 16164208452402602
 dialer hold-queue 100
 dialer pool 1
 dialer-group 1
 compress stac
 ppp authentication pap callin
 ppp pap sent-username FreeserveAccount.freeserve.co.uk password FreeservePassword 
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 172.16.0.54 25 interface Dialer1 25
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
no ip http server
!
logging trap notifications
logging 172.16.0.10
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 100 deny   udp any any eq ntp
access-list 100 deny   udp any any eq netbios-ns
access-list 100 deny   udp any any eq netbios-dgm
access-list 100 deny   udp any any eq netbios-ss
access-list 100 deny   tcp any any eq 139
access-list 100 deny   udp any eq netbios-ns any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
snmp-server community bdsltd RO 1
snmp-server location Business Direct Services Ltd, UK - 07966 425252
snmp-server contact Steve Warner                            
banner motd ^
   +-------------------------------------------------------------+
   |                                                             |
   |     You are authorised to use this System for approved      |
   |     business purposes only. Use for any other purpose       |
   |     is prohibited.                                          |
   |                                                             |
   |     All transactional records generated by using this       |
   |     System are the property of the Company and may be       |
   |     used by the Company for any purpose. Authorised         |
   |     and unauthorised activities may be monitored.           |
   |                                                             |
   |     For access to this system contact:                      |
   |                                                             |
   |               Business Direct Services Ltd on               |
   |                        07966 425252                         |
   |                                                             |
   +-------------------------------------------------------------+
^
privilege exec level 15 telnet
privilege exec level 15 rlogin
privilege exec level 1 show
privilege exec level 1 clear
!
line con 0
 exec-timeout 30 0
 login local
line vty 0 4
 access-class 1 in
 exec-timeout 30 0
 login local
!
ntp server 194.42.225.1
ntp server 194.42.224.130
ntp server 194.42.224.131
end

I use the following expect scripts to alter the configuration on my Cisco Router. The GTS Netcom or Freeserve script runs at 8am and the Demon script at 6pm. This script alters the differences between the 2 setups on Dialer1. This is so the NAT translations don't need to be changed, say if the interface was changed.

 

 

Last Updated 28 January 2001


Home | Networking | Teletext | About Us

Copyright 1997 - 2005 Business Direct Services Limited. All other trade marks acknowledged.
Using the products and services of Business Direct Services Limited confirms acceptance of their terms and conditions.