DEMON INTERNET - CISCO IOS DIAL-UP ISP CONFIGURATION EXAMPLE


Configurations below should work with all 1000series, 1600series, 2500series, 2600series, 3600series, 4x00series, 7x00series running IOS version 11.2 with IP+.

Substitute 158.152.104.116 for your static IP address. If unknown try pinging yourhostname.demon.co.uk or when connected to demon using win95/98 type winipcfg or winNT type ipconfig in a MS-DOS shell. 10.0.0.10 is an email gateway, syslog, snmp trap receiver and 10.0.0.20 is a users PC used for recieving McAfee Webcast updates.

ISDN (2503)

version 11.2
service timestamps debug datetime
service timestamps log datetime
service password-encryption
service compress-config
no service udp-small-servers
no service tcp-small-servers
!
hostname bdsltd
!
enable secret EnablePassword
!
username admin privilege 15 password AdminPassword
username support privilege 1 password SupportsPassword
username idiot privilege 0 password IdiotsPassword
!
ip subnet-zero
ip nat inside source list 1 interface BRI0 overload
ip nat inside source static tcp 10.0.0.10 25 158.152.104.116 25 extendable
ip nat inside source static udp 10.0.0.20 371 158.152.104.116 371 extendable
ip domain-name demon.co.uk
ip name-server 158.152.1.43
ip name-server 158.152.1.58
!
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
clock timezone GMT 0
clock summer-time BST recurring
!
interface Ethernet0
 description *****   Building LAN   *****
 ip address 10.0.0.1 255.255.0.0
 no ip redirects
 ip nat inside
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 description ***** ISDN Interface to Demon Internet (08452120667)*****
 ip address 158.152.104.116 255.255.255.0
 ip nat outside
 ip tcp header-compression passive
 encapsulation ppp
 dialer idle-timeout 120
 dialer map ip 158.152.1.222 broadcast 08452120667
 dialer-group 1
 compress stac
 ppp authentication pap callin
 ppp pap sent-username DemonAccount password DemonPassword
!
ip classless
ip route 10.0.0.0 255.0.0.0 Ethernet0
ip route 192.168.0.0 255.255.0.0 Ethernet0
ip route 172.16.0.0 255.240.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 158.152.1.222
ip route 158.152.1.222 255.255.255.255 BRI0
logging trap notifications
logging 10.0.0.10
access-list 1 permit 10.0.0.0 0.0.255.255
access-list 103 deny   udp any any eq ntp
access-list 103 deny   tcp any any eq smtp
access-list 103 permit ip any any
!
snmp-server community public RO
snmp-server community bdsltd RW 1
snmp-server trap-source Loopback0
snmp-server location Business Direct Services Ltd, UK - 01344 460075
snmp-server contact Steve Warner                                  
snmp-server host 10.0.0.10 public
dialer-list 1 protocol ip list 103
banner login ^Business Direct Services Ltd^
banner motd ^
   +-------------------------------------------------------------+ 
   |                                                             |
   |     You are authorised to use this System for approved      |
   |     business purposes only. Use for any other purpose       |
   |     is prohibited.                                          |
   |                                                             |
   |     All transactional records generated by using this       |
   |     System are the property of the Company and may be       |
   |     used by the Company for any purpose. Authorised         |
   |     and unauthorised activities may be monitored.           |
   |                                                             |
   |     For access to this system contact:                      |
   |                                                             |
   |                        BDS Ltd on                           |
   |                       01344 460075                          |
   |                                                             |
   +-------------------------------------------------------------+
^
privilege exec level 15 telnet
privilege exec level 15 rlogin
privilege exec level 1 show
privilege exec level 0 clear counters
privilege exec level 1 clear
!
line con 0
 exec-timeout 30 0
 login local
line aux 0
 transport input all
 exec-timeout 30 0
 login local
line vty 0 4
 exec-timeout 30 0
 login local
!
ntp server 158.152.1.65
ntp server 158.152.1.76
ntp server 194.159.253.2
end

 

 

Last Updated 28 January 2001


Home | Networking | Teletext | About Us

Copyright 1997 - 2005 Business Direct Services Limited. All other trade marks acknowledged.
Using the products and services of Business Direct Services Limited confirms acceptance of their terms and conditions.